
 

 
Cross-Platform C/C++ Development with Eclipse CDT 

Using Eclipse as a universal C++ IDE for Linux and Windows requires navigating a few issues in setup and functionality. Here's how.  
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URL:http://drdobbs.com/cpp/232300575  
 
I've had to do a bit of cross-platform development for various projects over the years. For most of my development, my IDE of choice is Eclipse on Linux. 
To build in Windows, I create a new Visual Studio project and manually import the source files. This works reasonably well for small, one-off projects, but 
it's a pain for larger projects that require regular modifications. One issue is that new files added to the Eclipse project must manually be imported to the 
Visual Studio project. Ideally, all changes made to the project in the Linux environment should be automatically realized in the Windows environment. 
Eclipse is a cross platform IDE, so this should be a snap, right? This article explores how to create one Eclipse project that can be used to compile on 
Windows using the Visual Studio compiler or on Linux using GCC, and share the source code via SVN. We'll also explore using a cross compiler on Linux 
to build a Windows executable. First, here's a bit on the environment.  

Installation Woes 

In both environments, I'm running 64-bit Eclipse Indigo with the plugins CDT, Subclipse, and SVNKit (included with Subclipse). Take a look at Figures 1 
and 2 for version information. I previously tried Subclipse version 1.8 but couldn't get it to work with SVNKit. For Visual Studio, I'm using the 2010 
Express Edition.  

  
Figure 1: Eclipse Installation on Linux.  
 

  
Figure 2: Eclipse plugins on Windows.  
 
Installing Subclipse in Eclipse on Windows was problematic. Several times, I attempted to install by pointing to the URL, but the installation would pause 
indefinitely at around 30% complete. Downloading the zip file (site.1.6.18.zip) from the Subclipse website finally did the trick. However, I had to de-select 
the "SVN Revision Graph" option under "Subclipse" before the installation would work; the installer complained that the feature couldn't be found.  

Once SVN was installed, a configuration step had to be completed under Linux and Windows: We need to tell the IDE which SVN library to use. By 
default, it tries to use the JavaHL library, which we didn't install. To change from JavaHL to SVNKit, browse to Window→Preferences. In the Preferences 
screen, expand Team and select SVN. Under "SVN Interface," select SVNKit and you'll see a screen similar to Figure 3.  
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Figure 3: Configuring Subversion.  
 
Now the IDE is setup on Windows and Linux, and we can create a project. All the example projects will use the C++ source code shown in Listing One:  

Listing One: A simple C++ program as an example. 

#include <iostream> 
include <list> 
 
using namespace std; 
 
int main() 
{ 
 list<int> lst; 
 
 lst.push_back(3); 
 lst.push_back(1); 
 lst.push_back(4); 
 lst.push_back(1); 
 lst.push_back(5); 
 lst.push_back(9); 
 lst.push_back(2); 
 lst.push_back(6); 
 lst.push_back(5); 
 lst.push_back(3); 
 
 lst.sort(); 
 
 cout << "sorted list: "; 
 
 for (list<int>::iterator itr = lst.begin(); itr != lst.end(); itr++) 
  cout << (*itr) << " "; 
 
 cout << endl; 
 
 return 0; 
} 

I first create a project under Windows and go through the process of configuring the Visual Studio toolchain. (We'll later look at porting the project to 
Linux, followed by creating an app under Linux and porting to Windows.)  

Eclipse Windows Toolchain Setup 

Before Eclipse can use the Visual Studio compiler and take advantage of code completion, a little setup is required. Indigo comes with a toolchain pointed 
at the Visual Studio tools, but it doesn't have the include directory configured in the IDE, and the Visual Studio tools aren't in the path variable by default. 

Fixing the last problem is easy: Visual Studio comes with a batch file (Visual Studio Command Prompt (2010)) that sets the appropriate environment 
variables for running Visual Studio. Running the batch file updates the path variable and adds few other variables that we'll be using to configure Eclipse. 
For my testing, I first ran the batch file (Start→Microsoft Visual Studio Expresss 2010→Visual Studio Command Prompt (2010)), and then changed to the 
Eclipse directory and launched Eclipse from the command line.  

Next, it's time to create a project and deal with the missing include directory problem.  

Start Eclipse from the VS command prompt and select File→New→C++ Project. Name the project sort_win. Select "Empty Project" and, under 
toolchains, select Microsoft Visual C++. Click finish. Next, add a source file called main.cpp and paste in the code mentioned above. At this point, the 
program should compile and link without error. But the IDE does not have the path to the include files, causing it to complain and mark every line as an 
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error. Let me stress that the program still compiles.  

In addition to claiming numerous errors and complaining about missing include files, code completion does not work. To fix this issue (and get rid of the 
errors), we need to point the IDE to the include directory. This is where a Visual Studio project comes in handy. To figure out what paths Visual Studio 
uses, I created a C++ project. After a little browsing, I found the default include directories: right-click on the project, select Properties, then expand 
Configuration Properties and select VC++ Directories (Figure 4).  

  
Figure 4: The project in Eclipse under Windows.  
 
The directory we're interested in is Include Directories. Editing this value brings up a list of four configured directories: two of them are for Windows 
SDKs that we don't need, and another is for atlmfc stuff, which is also not needed. The only useful directory to us is $(VCInstallDir)\include.  

Earlier, I mentioned that running the VS batch file would setup variables that will be useful. VCInstallDir is one of those variables. Now, we just need to 
add this include path to the Eclipse project.  

In Visual Studio, using an environment variable is done by surrounding the variable with parentheses. In Eclipse, you must use curly brackets. The path to 
add to Eclipse is ${VCInstallDir}\include.  

There are two locations where the path can be added. In Eclipse, right-click on the project and select Properties. Expand C/C++ General and select Paths 
and Symbols. Select either C source file or C++ source file on the Include tab. Click the Add button and place the include path in the directory textbox. 
After adding the directory, you might still have a bunch of the code completion that the database didn't rebuild. To rebuild the database, right-click on the 
project, select Index→Rebuild, and the errors will disappear.  

Starting From Windows 

At this point, we have a project in Eclipse under Windows that will build with Visual Studio compiler, there are no errors or warnings in the IDE, and code 
completion works. The next step is to get the source onto a Linux machine and configure a Linux build. I'm using SVN to transfer the project between 
machines but you can copy the project to your Linux system instead.  

Once the source is on your Linux system, open the project in Eclipse. You will receive errors and warnings about missing include files and unresolved 
symbols, and the application won't build. The IDE is using Windows paths and build tools, which are obviously not valid under Linux. The first thing we 
need to do is create debug and release builds for Linux that point to the correct compiler.  

right-click on the sort_win project and select Properties. Expand C/C++ Build and click on Settings. Select the Manage Configurations... button, and select 
the New... button, in the Manage Configurations window. Under name, enter Debug-Linux, select the Import predefined radio button, and select 
Executable→Linux GCC→Debug. Select OK. Repeat this process substituting Release for Debug to create a Release build (see Figure 5).  

  
Figure 5: Configuring Eclipse for a project on Linux.  
 
After creating the new build configurations, enable Debug-Linux: right-click on the project, browse to Build Configurations→Set Active→Debug-Linux. 
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The IDE will now use GCC to build the application, but the code completion index is incorrect. When building applications across platforms, each 
platform needs its own index. The IDE has a setting to use the active configuration for creating the index.  

To enable this feature, right-click on the project and select Properties. Expand C/C++ General and select Indexer. Check the Enable Project Specific 
Settings at the top of the window, and select the Use Active Build Configuration at the bottom of the window. Select OK. If the errors don't disappear right 
a way, rebuild the index as described previously (Figure 6).  

  
Figure 6: Configuring the Indexer options in Linux.  
 
Starting from Linux 

Creating a project in Linux and transferring to Windows is a nearly identical process. Select File→New→C++ Project. Name the project sort_lin, select 
Empty Project under project type, and select Linux GCC under Toolchains (Figure 7). Select Finish.  

  
Figure 7: The new project dialog in Linux.  
 
Next, add a main.cpp source file with the same source that was used in the Windows program. Once the project is complete, transfer it to your windows 
machine, launch Eclipse from the Visual Studio command prompt and open the project. You should notice that we have the same problem that we 
experienced previously when transferring from Windows to Linux: The IDE shows a bunch of errors and the project won't build. We need to add debug 
and release build configurations for Windows. Follow the previous instructions for adding new build configurations under Linux, but use the 
Executable→Microsoft Visual C++ →[Debug | Release] option. Next, add the path ${VCInstallDir}\include to both of the new build configurations.  

If you activate the windows configurations, the project will build, but the IDE will still show a bunch of errors and warnings. As we did in Linux, we need 
to enable project-specific indexer settings. Follow the previous instructions to enable the settings and rebuild the index if needed. Make sure to add the 
Visual Studio path as mentioned previously before enabling project-specific indexer settings. A few times, I misspelled the directory and it defaulted back 
to use a fixed-build configuration. Double-check your settings if the errors don't disappear after rebuilding the index.
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Cross Compile Linux to Windows

Another option for building Windows executables with Eclipse on Linux is to use a cross compiler. To use this option, CDT must have the cross compile 
extension enabled, and a cross compiler must be installed. Under Ubuntu 10.10, installing the mingw32 package will bring in everything required to build 
the sample project with the MinGW cross compiler. Next, we'll install CDT cross compile support.  

To install CDT cross compile support, navigate to Help → Install New Software... In the Work With textbox, type cdt to filter down to CDT settings and 
select the CDT option. Expand CDT Optional Features and check the C/C++ Cross Compiler Support option. Hit Next and follow the instructions to 
complete the installation (Figure 8).  

  
Figure 8: Setting up Windows cross-compilation on Linux.  
 
Installing the CDT cross compiler support provides new build configuration options. To see the new options, follow the previous instructions for creating a 
new build configuration. Under the Import Predefined dropdown box, two new options are available: Executable→Cross GCC→Debug, and 
Executable→Cross GCC→Release. Create a new build configuration called Debug-Win and select the Cross GCC→Debug option.  

When this configuration is selected, you'll notice a new option in the project settings called Cross Settings. Open the project settings, select Cross Settings, 
and enter i586-mingw32msvc- into the prefix textbox. If the prefix box is left empty, the IDE will use the default system tools for linking and compiling 
(Figure 9).  

  
Figure 9: The Cross Settings dialog box in Linux.  
 
A Few Good Options 

Eclipse offers a few options for creating cross-platform projects. It takes a bit of futzing, but developing between Linux and Windows works seamlessly 
once the project is setup. And there are other options that we didn't cover such as using GCC on Linux and Windows or creating makefiles by hand. Each 
option has its own set of quirks for dealing with include directories, maintainability, third-party libraries, and debugging.  

In this article, we covered handling include directories and the options covered are arguably the easiest to maintain (since Eclipse automatically handles 
the makefile). If you want to debug on both platforms or use third-party libraries, there's a bit more work to do depending on the option chosen for cross-
platform development. But we'll leave that for another time.  

Ben DuPont is a software engineer. After 10 years of developing software and systems in a corporate environment, he founded Nebland Software, an 
independent software consulting company. 
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